Back to overview
Resolved

Site Issues

Sep 1, 2026 at 2:36pm UTC
Affected services
API Health Check
MagicSchool Signin
MagicSchool Student Signin
magicschool.ai

Resolved
Sep 2, 2026 at 7:21pm UTC

Site Issues Resolved

Updated
Sep 2, 2026 at 6:15pm UTC

We are experiencing intermittent site issues from an upstream provider causing site slowness, we are working with our provider to remediate the problem.

Updated
Sep 1, 2026 at 10:00pm UTC

Site issues resolved

Created
Sep 1, 2026 at 2:36pm UTC

We are experiencing intermittent site issues from an upstream provider causing site slowness, we are working with our provider to remediate the problem.