Back to overview
Resolved

Site Issues

Aug 26, 2026 at 3:14pm UTC
Affected services
MagicSchool Signin
MagicSchool Student Signin
magicschool.ai

Resolved
Aug 26, 2026 at 5:06pm UTC

Intermittent issues have been resolved.

Created
Aug 26, 2026 at 3:14pm UTC

We are experiencing intermittent site issues from an upstream provider causing site slowness, we are working with our provider to remediate the problem.