Back to overview
Resolved

Site Issues

Aug 26, 2026 at 6:15pm UTC
Affected services
API Health Check
MagicSchool Signin
MagicSchool Student Signin
magicschool.ai

Resolved
Aug 27, 2026 at 5:39pm UTC

Site issues resolved.

Updated
Aug 27, 2026 at 5:14pm UTC

Issues resolved.

Updated
Aug 27, 2026 at 1:52pm UTC

We are experiencing intermittent site issues from an upstream provider causing site slowness, we are working with our provider to remediate the problem.

Updated
Aug 26, 2026 at 7:48pm UTC

Issues Resolved

Created
Aug 26, 2026 at 6:15pm UTC

We are experiencing intermittent site issues from an upstream provider causing site slowness, we are working with our provider to remediate the problem.