Back to overview
Resolved

Issues Resolved

Aug 27, 2026 at 7:55pm UTC
Affected services
API Health Check
MagicSchool Signin
MagicSchool Student Signin
magicschool.ai

Resolved
Aug 27, 2026 at 7:55pm UTC

Issues with our site have been resolved.