Back to overview
Resolved

Maintenance

Sep 3, 2026 at 3:30am UTC
Affected services
API Health Check
MagicSchool Signin
MagicSchool Student Signin
magicschool.ai

Resolved
Sep 3, 2026 at 5:17am UTC

Maintenance Complete

Created
Sep 3, 2026 at 3:30am UTC

Planned maintenance happeing