Back to overview
Degraded

Intermittent access issues affecting MagicSchool websites

Nov 18 at 05:50am MST
Affected services
API Health Check
MagicSchool Signin
MagicSchool Student Signin
magicschool.ai

Resolved
Nov 18 at 10:45am MST

The issue has been resolved by Cloudflare; the MagicSchool website and application should be working as expected again.

Updated
Nov 18 at 08:23am MST

A fix has been implemented by Cloudflare, and believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.

Created
Nov 18 at 05:50am MST

MagicSchool websites and applications are experiencing service interruptions due to a broader outage and degradation of one of our third-party service providers.

Our team is closely monitoring the situation and will share updates as soon as we know more. We appreciate your patience and understanding as this gets resolved.